is cvs relatively safe?

Jesse Tie-Ten-Quee highos at linuxfromscratch.org
Fri Jun 28 14:25:11 PDT 2002


Yo,

On Wed, Jun 26, 2002 at 11:40:17AM -0500, Justin Friel wrote:
> i recently finished a lfs/blfs workstation using lfs 3.3.  i liked it so
> much i am now thinking of switching my samba server to the current cvs.

Why fix something that isn't broken? :-)

> i have read about several packages having problems with gcc 3+.  is general
> compatability with gcc3 better than it was a few months ago, or am i going
> to be spending a lot of time hunting down patches?

Yes, there still are issues with gcc3, however as more and more times
goes by the less and less it has an effect on you.  I've been running
LFS CVS for a month on my laptop.  Haven't really run into any problems
and i've installed quite a few things.

OpenSSH, Samba, MySQL, Apache, X11, KDE3, gtk, mplayer, xein, etcetc all
work fine.

> is there a way to use both gcc 2.95 and 3.1, or is this not too feasable.

Yes, there is a hint written on exactly this issue.

> finally, has anyone had success with lfs and development(2.5) kernels? or am
> i just asking for it.

It is not recommended to build an LFS system with a 2.5 kernel.  I would
suggest instead just building with 2.4, then once the system is up and
running switch to a 2.5 kernel.  You don't gain anything by using 2.5
from the get go.

-- 
Jesse Tie-Ten-Quee  ( highos at linuxfromscratch dot org )
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list