[lfs-dev] test failure in tar-1.30

Ken Moffat zarniwhoop at ntlworld.com
Sat Dec 23 11:36:52 PST 2017


On Fri, Dec 22, 2017 at 04:10:35PM -0600, Bruce Dubbs wrote:
> Berzerkula wrote:
> > On Fri, 22 Dec 2017 15:04:47 -0600
> > Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
> > 
> > > Ken Moffat wrote:
> > > > Just an initial note that I'm getting one test failure in tar:
> > > > 
> > > >    92: link mismatch                                   FAILED (difflink.at:19)
> > > > 
[...]
> > 
> > Hello Bruce,
> > 
> > Which mailing list? Have a link?
> > 
> > The test passes for me. Using a current CLFS build in the running
> > instance. Two people. One passes. One fails. Need more info here. The
> > patch may help it PASS, but I want to know why, and there is not enough
> > info.
> 
> http://lists.gnu.org/archive/html/bug-tar/2017-12/txtHO4Jt7HaLP.txt

and
> 
> http://lists.gnu.org/archive/html/bug-tar/2017-12/msg00027.html

Looks like a broken test, although a followup (nsg00028) suggests
other random failures on fedora in different architectures.

FWIW I get the same failure on the completed system when building as
a user, and it is not related to forcing an unsafe configure (which
we have to do in chroot).  But I haven't tried building it on any
older systems, nor fixing the test to match that second link.

ĸen
-- 
Truth, in front of her huge walk-in wardrobe, selected black leather
boots with stiletto heels for such a barefaced truth.
                                     - Unseen Academicals


More information about the lfs-dev mailing list