[lfs-dev] gcc pass 1: perl binaries are mismatched

Roger Koehler roger.o.koehler at gmail.com
Fri Jun 17 07:47:45 PDT 2016


> On Jun 14, 2016 7:15 PM, "Ken Moffat"  >One comment said it can be called
>
> > when an external program, such as texinfo, calls an external library
> > that is built against a different perl version.  In that case, perl
> > had been upgraded but one of the perl dependencies of the particular
> > package giving the error had been missed.
>
> Wow!
>
> > That's one of the reasons I don't update perl versions on existing
> > systems if I can help it (i.e. I patch the old version or update
> > just the appropriate module if there is a vulnerability I'm aware
> > of).

I didn't delete anything. I just reinstalled the older version of Perl
using LFS instructions over the newer one. I can now successfully build LFS
with jhalfs. In the future, when a new version of Perl comes out, I'll
treat it as a tool chain update, which apparently it is, and rebuild the
whole system.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-dev/attachments/20160617/28fcce22/attachment.html>


More information about the lfs-dev mailing list