[lfs-dev] gcc pass 1: perl binaries are mismatched

Roger Koehler roger.o.koehler at gmail.com
Tue Jun 14 18:27:46 PDT 2016


On Jun 14, 2016 7:15 PM, "Ken Moffat"  >One comment said it can be called
> when an external program, such as texinfo, calls an external library
> that is built against a different perl version.  In that case, perl
> had been upgraded but one of the perl dependencies of the particular
> package giving the error had been missed.

Wow!

> That's one of the reasons I don't update perl versions on existing
> systems if I can help it (i.e. I patch the old version or update
> just the appropriate module if there is a vulnerability I'm aware
> of).

Another lesson learned by hard knocks! Thank you, LFS! (Not complaining.
It's a great way to learn. You tend to remember things learned that way.)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-dev/attachments/20160614/30379226/attachment.html>


More information about the lfs-dev mailing list