[lfs-dev] Binutils 2.25 - unrecognized relocation

Nathan Coulson conathan at gmail.com
Sun Feb 14 13:10:04 PST 2016


Not sure if there is any point posting this (Ran into this issue, I
have deviated from the lfs books [64bit libraries in /tools/lib, but
32bit libraries in /tools/lib/i386-linux-gnu], and solved it), but
thought I'd post my findings.



lib/i386-linux-gnu/crti.o: unrecognized relocation (0x2b) in section
`.init'  (From the path, I believe it was using my system's ld and not
the one in /tools)

Came across this while building chapter 5 gcc pass2

also documented on https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=808181




I believe for myself this was due to me not setting CC,CXX,AR,RANLIB
prior to calling configure (my host uses binutils 2.23.2), and solved
it with

LD=x86_64-lfs-linux-gnu-ld

(The CC/CXX flags cause issues when I try to build the 32bit
libraries, and I am guessing that they would be using the correct ld
if they were set)


anyway, as far as I know I am the only one with this issue, and
everyone else who follows the book probably has no issues building it.
(in which case what I posted is irrelavent).  But *shrug*, if I am
wrong, then this could help.

-- 
Nathan Coulson (conathan)
------
Location: British Columbia, Canada
Timezone: PST (-8)
Webpage: http://www.nathancoulson.com


More information about the lfs-dev mailing list