[lfs-dev] Package Freeze

Thierry Nuttens tnuttens at gmail.com
Mon Aug 15 15:12:04 PDT 2016


>>>> Check for /tools/include/c++/6.2*/algorithm  It should have been
>>>> installed
>>>> in pass1.
>>
>> It seems to be installed by libstdc++ as it's a c++ lib.
>> http://downloads.nutyx.org/logs/development/x86_64/chroot/libstdc++.log
>> and passing --with-gxx-include-dir=/tools/$LFS_TARGET/include/c++/$version
>> to gcc_pass2 didn't help. Do you see anything in gcc_pass1 that
>> algorithm header file is install ?
>
>
>> Any way I will check again on gcc 6.1 when this file is installed. I
>> will findout I hope
>
>
> It's not clear whether the file is not installed or just not found.  If not
> found try setting C_INCLUDE_PATH and/or CPLUS_INCLUDE_PATH.
>
>
>   -- Bruce
>
I guess I'im reach the limits of my knowledge in this.

In gcc_pass2:
I tried passing CPLUS_INCLUDE_PATH=/tools/x86_64-lfs-linux-gnu/include
to the ./configure

same error

I tried rsync -a /tools/x86_64-lfs-linux-gnu/include/c++/ /tools/include/c++/

same error


More information about the lfs-dev mailing list