[lfs-dev] perl tests loop at 100% CPU in current SVN

Ken Moffat zarniwhoop at ntlworld.com
Sun Aug 7 18:04:10 PDT 2016


On Mon, Aug 08, 2016 at 01:37:27AM +0100, Ken Moffat wrote:
> On Sun, Aug 07, 2016 at 08:37:32PM +0100, Ken Moffat wrote:
> > On Sun, Aug 07, 2016 at 02:14:42PM -0500, Douglas R. Reno wrote:
> > > On Aug 7, 2016 12:12 PM, "Ken Moffat" <zarniwhoop at ntlworld.com> wrote:
> > > There are a couple of memory leaks and such that were reported for Perl a
> > > couple of days ago. I wonder if you ran across some of them.
> > > 
> [...]
> > 
> > For perl, let's see what happens without gold.
> > 
> It's now hanging (I guess 'looping' is a more accurate description)
> at the exact same place in the tests [ lib/Benchmark ].
> 
> I would normally assume a loop like this was different from a memory
> leak, but I have no details of what you referred to.
> 
> Looking at that test script, I have no idea how to debug it.  It
> worked in 5.24 on the haswell at the end of May / beginning of June.
> Oh, and I don't have gdb or strace in /tools on this build.
> 
That box used to be my development machine, so it has several
filesystems for building.  And I urgently need a fresh system to
look at texlive re the tlmgr ticket.  So, since my 20160527 build
worked on the haswell, I'll use a fresh partition and try that
version for LFS.

If that works, then either the newer toolchain, or the newer (4.7)
headers, or something AMD-specific is the problem.  And if it
doesn't then it's probably AMD-specific.

ĸen
-- 
`I shall take my mountains', said Lu-Tze. `The climate will be good
for them.'     -- Small Gods


More information about the lfs-dev mailing list