[lfs-dev] util-linux chapter 5 (cannot find -ltinfo)

David Buchan davidsbuchan at gmail.com
Mon Jan 27 14:57:18 PST 2014


Hi,

I'm getting the following error when compiling util-linux in chapter 5.
Tried from dev 2014 onwards.
  CCLD     more
/mnt/lfs/tools/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.8.2/../../../../x86_64-unknown-linux-gnu/bin/ld:
cannot find -ltinfo
collect2: error: ld returned 1 exit status
Makefile:5603: recipe for target 'more' failed
make[2]: *** [more] Error 1
make[2]: Leaving directory '/mnt/lfs/home/lfs/sources/util-linux-2.24.1'
Makefile:10303: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/mnt/lfs/home/lfs/sources/util-linux-2.24.1'
Makefile:4315: recipe for target 'all' failed
make: *** [all] Error 2

The above error comes with MAKEFLAGS unset. If it is set to -j 4 then I get:
fdisks/cfdisk.c: In function 'get_string':
fdisks/cfdisk.c:465:20: warning: comparison between signed and unsigned
integer expressions [-Wsign-compare]
  if ((c = getch()) == ERR) {

and

unknown-linux-gnu/bin/ld: cannot find -ltinfo
collect2: error: ld returned 1 exit status
Makefile:6251: recipe for target 'ul' failed

I've tried stabbing in the dark with --disable-ul but the error moves onto
something else.
Any ideas?

Ta

David
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-dev/attachments/20140127/203a4046/attachment.html>


More information about the lfs-dev mailing list