[lfs-dev] LFS SVN and Systemd Report

Armin K. krejzi at email.com
Thu May 31 15:18:35 PDT 2012


On 06/01/2012 12:08 AM, Jeremy Huntwork wrote:
> On 5/31/12 6:01 PM, Armin K. wrote:
>> pkg-config 0.26 uses glib2 and does not ship glib1 anymore. And since
>> LFS/BLFS tends to use latest stuff, glib 2.32 requires python for gdbus
>> stuff and libffi for some other stuff ... Do note that pkg-config 0.25
>> can be still built flawlessly. It can be installed in temporary system,
>> then just symlink pkg.m4 from /tools/share/aclocal into
>> /usr/share/aclocal and you should be good.
>
> Hmm, if it requires glib2, then they need to update their website. At
> that rate, just use 0.25 - as you say, works great here, too and
> probably will for some time to come.
>
> JH

Also, another possible workaround is to use glib2 <= 2.28 which doesn't 
require python and libffi at build time. And since pkg-config only 
requires libglib-2.0, one can make static libglib-2.0.a and link 
pkg-config against it.



More information about the lfs-dev mailing list