[lfs-dev] LFS SVN and Systemd Report

Jeremy Huntwork jhuntwork at lightcubesolutions.com
Thu May 31 15:17:16 PDT 2012


On 5/31/12 6:10 PM, Andrew Benton wrote:
> On Thu, 31 May 2012 22:38:21 +0100
> Jeremy Huntwork<jhuntwork at lightcubesolutions.com>  wrote:
>
>> Since when does glib require Python?
>
> I think Python's been a required dep since glib-2.32. It may be
> possible to build glib without python but it will need more than
> configure switches.
>
>> Are you using glib2? IIRC,
>> pkg-config up until recently shipped with glib1 sources and built that
>> in its own build system. In fact pkg-config's page says it uses
>> glib-1.2.10 - that's lightweight and has no external deps.
>
> glib-1.2.10 is 11 years old and would probably need a lot of work to
> get it to compile.

It still amazes me that pkg-config requires any other external library. 
glib1 wasn't bad since it was shipped alongside it and had no other 
deps, fairly lightweight. But switching to glib2 was just ridiculous. 
All that pkg-config is doing is parsing a text file and spitting out 
results. Makes me want to look it over and rip out that dependency...

JH



More information about the lfs-dev mailing list