[lfs-dev] LFS SVN and Systemd Report

Bruce Dubbs bruce.dubbs at gmail.com
Thu May 31 14:20:33 PDT 2012


Dan Nicholson wrote:

> Congratulations, you're off and running with the autotools! 

Well Dan, I've run into a problem with autoconf that I can't figure out 
how to solve.  configure.ac has several lines like:

PKG_CHECK_MODULES(KMOD, [libkmod >= 5])

Now that's a reasonable check, but requires cfg.m4 which is installed by 
pkg_config.  We don't have that in LFS.  I don't know how to get around it.

To answer a question you may not be up to speed on, we don't install 
pkg-config in lfs because the pkg-config developers inconveniently made 
it depend on glib.  The dependencies are:

pkk-config
   glib (required)
     libffi (required)
     Python (required)
       pkg-config (recursive, but can work around)
     pcre  (recommended)
     several optional dependencies

We are in the position of needing to install four packages (one 
incomplete) just to satisfy the systemd build methodology that requires 
things we don't need for udev.

Perhaps the way to go is to create a custom Makefile.udev and then

make -f  Makefile.udev
make -f  Makefile.udev install

bypassing autotools.

   -- Bruce



More information about the lfs-dev mailing list