[lfs-dev] LFS SVN and Systemd Report

Ken Moffat zarniwhoop at ntlworld.com
Thu May 31 14:19:31 PDT 2012


On Thu, May 31, 2012 at 02:10:44PM -0500, Bruce Dubbs wrote:
> Ken Moffat wrote:
> > 
> >  Failed to link:
> > 
> > CC cdrom_id
> > CC ata_id
> > CC accelerometer
> > /usr/bin/ld: cannot find -ludev
> > collect2: error: ld returned 1 exit status
> > LD udevd failed
> > root in chroot /building/systemd-183#
> > 
> >  You know I do things differently, so here is my environment in case
> > it's my fault:
> 
> The environment shouldn't be a factor.  You should have seen:
> 
> CC libudev-device-private
> CC libudev-device
> CC libudev-enumerate
> CC libudev-list
> CC libudev-monitor
> CC libudev-queue-private
> CC libudev-queue
> CC libudev-util
> CC libudev
> libudev.so.1 created

 got that part
> ...
> CC accelerometer
> LD udevd
> LD udevadm
> ...
> Finished

 but broke in D udevd
> 
> Look at the make.sh script.  It should have:
> 
> ########## LINKING
> 
> cd build
> ...
> LDFLAGS="-pthread -Lbuild  -lrt -lblkid  -lkmod -L.. -ludev"
> link udevd
> ...
 Yes, it has all of those lines.  build contains all the objects as
well as libudev-local.a and ../ contains libudev.so.1{,.0.0}.

 Ah!  No libudev.so symlink.  Added symlink for libudev.so in ../ and
retried : it rebuilt / relinked and got through to Finished.

 Is it worth me testing that this does work for xorg/Mesa ?  Or are
you concentrating on the patches to separate it ?

ĸen : still reading the 'goat' book - found my printed copy, didn't
know that was a goat on the cover (Dan's link to autobook at redhat)
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the lfs-dev mailing list