[lfs-dev] linux-3.4 needs patch to build

Matthew Burgess matthew at linuxfromscratch.org
Tue May 29 09:07:38 PDT 2012


On Tue, 29 May 2012 09:02:17 -0700 (PDT), Fernando de Oliveira <famobr at yahoo.com.br> wrote:

> Digging into this since yesterday evening, discovered first that 3.4 is
> dev and stable version is 3.3.7, second, the error is well known:
> 
> http://us.generation-nt.com/answer/linux-next-build-failure-after-merge-final-tree-help-207537361.html

3.4 is *not* dev.  See http://kernel.org/ - 3.4 is 'mainline', 3.3.7 is stable.  But, as
soon as Greg releases 3.4.1, that will be deemed 'stable' as well.

As far as the patch goes, I don't mind adding it, though it would be nice if you
or someone else can figure out why it's needed in certain configurations and
not in others.  If you see a package upgrade committed by me in svn, you can be
assured that it built for me at least.  I obviously can't test every combination
of hardware and/or kernel configs (my kernel is as minimal as possibly for my
needs).

Regards,

Matt.




More information about the lfs-dev mailing list