[lfs-dev] Broken sound (glibc).

Ken Moffat zarniwhoop at ntlworld.com
Tue May 1 17:41:33 PDT 2012


On Wed, May 02, 2012 at 12:53:50AM +0100, Andrew Benton wrote:
> On Tue, 01 May 2012 23:12:16 +0100
> Matt Burgess <matthew at linuxfromscratch.org> wrote:
> 
> 
> >   This is upstream bug 13579
> > (http://sourceware.org/bugzilla/show_bug.cgi?id=13579) and the
> > attached patch should fix it.  Would you mind giving it a try please?
> > 
> 
> The patch attached to that bug is essentially the same as the one I
> attached earlier (it differs only in the comments and line offsets).
> I've been using that patch since last August. It still applies to glibc
> head. It fixes the problem.
> 
> Andy
 Agreed it's essentially the same.  Anyway, I tried Matt's version
and confirm it fixes it.

 The downside was that I got one new (to me) test failure in
iconvdata:
make[2]: *** [/usr/src/glibc-build/iconvdata/tst-tables.out] Error 1
make[1]: *** [iconvdata/tests] Error 2
make[2]: [/usr/src/glibc-build/posix/annexc.out] Error 1 (ignored)
make: *** [check] Error 2

 x86_64, running linux-3.4.0-rc4.  I didn't save the test logs
(hadn't expected the failure, to be honest) and *something* flagged
up a red failure from the bootscripts when I rebooted to test it
(about two lines from the end of the messages) - but I suspect that
is par for the course when rebuilding glibc in a running system.

 Figuratively speaking, Thanks for the pony ;-)

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the lfs-dev mailing list