[lfs-dev] LFS SVN urrent build results

Bruce Dubbs bruce.dubbs at gmail.com
Mon Dec 24 08:23:13 PST 2012


I ran a new build test last night and had some issues.  Just reporting
right now.
Numbers refer to jhalfs order.

071-glibc
  annexc (ignored) error
  cputimer1 error
  run-conformtest (ignored)

  These have been around for a while and are documented in the book.

075-binutils
   Running /sources/binutils-2.23.1/ld/testsuite/ld-ifunc/ifunc.exp ...
   FAIL: Common symbol override ifunc test 1b

   This is new to me, but there are some mentions at
   http://sourceware.org/bugzilla/show_bug.cgi?id=14778
   but the changes mentioned are in 2.23.1.  Perhaps more
   research is needed to get a patch or jsut mention it in the text
   of the book.

079-gcc
   libmudflap pass55-frag.cxx fails.  I think it had been fixed, but
is a regression.
   The libmudflap issue is already mentioned in the book.

111-gzip
   zgrep-signal: set-up failure: signal handling busted on this host
   ERROR: zgrep-signal

   This is new, but mentioned in a couple of places in Google.  I
suspect it is because of the
   scripting and hot have a direct tty, but I'm not sure.

I also ran into a problem with jhalfs not exiting properly, although
all the builds seems to complete.
I used

if [ -h $LFS/dev/shm ]; then
   link=$(readlink $LFS/dev/shm)
   mkdir -p $LFS/$link
   mount -vt tmpfs shm $LFS/$link
   unset link
else
   mount -vt tmpfs shm $LFS/shm
fi

to mount shm.  The umount process at the end did not work properly.
There may also be a related error somewhere in the build process as
there were two processes hanging around after jhalfs completed.  I'm
going to run another test build today and will investigate that in a
little more detail.

  -- Bruce



More information about the lfs-dev mailing list