[lfs-dev] version mismatch in udev/Makefile.lfs

Bruce Dubbs bruce.dubbs at gmail.com
Sun Dec 2 14:35:10 PST 2012


Pierre Labastie wrote:
> It seems that the VERSION=196 instruction should be changed
> to VERSION=196-2 in udev-lfs-196-2/Makefile.lfs.
>
> Otherwise the 'include' instructions fails when running
>
> make -f udev-lfs-196-2/Makefile.lfs

Humm, thanks Pierre.  I'll have to think about how to address that. 
There are some places that need the systemd-version and others that 
would need the lfs version.

Of course the next version would be udev-lfs-196-3 unless systemd-197 
comes out.  How does the attached patch work for you?  Apply with:

tar -xf systemd-196.tar.xz
cd systemd-196
tar -xf ../udev-lfs-196-2.tar.bz2

cd udev-lfs-196-2
patch -Np0 -i /file-location/systemd196.patch
cd ..

make -f udev-lfs-196-2/Makefile.lfs

   -- Bruce


-------------- next part --------------
A non-text attachment was scrubbed...
Name: systemd196.patch
Type: text/x-patch
Size: 880 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-dev/attachments/20121202/16a59804/attachment.bin>


More information about the lfs-dev mailing list