[lfs-dev] Possible problem with current glibc (LFS 7.2 cant recompile LFS 7.2)

Marius Tolzmann tolzmann at molgen.mpg.de
Sat Aug 25 06:36:47 PDT 2012


have you tried compiling glibc with --enable-obsolete-rpc?

I think this was added to glibc 2.16. to make it possible to compile 
with the obsoleted rpc code/headers which was removed in earlier glibc 

I think this switch was added because tirpc is not ready yet to replace 
sunrpc (glibc) completely and will be removed as soon as tirpc is ready.

see also 

Best, marius..

On 25.08.2012 14:47, Jasmine Iwanek wrote:
> Onto my second pass building 7.2 dev and it would appear that without
> the obsolete rpc interfaces that glibc 2.16 wont compile, I grabbed
> rpc/types.h and put it in usr/include/rpc and all was good to go again.
> Don't know if anyone else has as yet tried building 7.2 in 7.2 but I
> think this may be worth looking into.
> rpc_clntout.c:34:23: fatal error: rpc/types.h: No such file or
> directory
> compilation terminated.
> make[2]: *** [/mnt/lfs/sources/glibc-build/sunrpc/cross-rpc_clntout.o]
> Error 1
> make[1]: *** [sunrpc/others] Error 2
> make: *** [all] Error 2
> --
> Jasmine Iwanek

More information about the lfs-dev mailing list