Is there a specific reason why dash and mawk isn't supported?

Nathan Coulson conathan at
Thu May 5 17:17:01 PDT 2011

On Thu, May 5, 2011 at 3:48 PM, Andrew Benton <b3nton at> wrote:

> On Thu, 5 May 2011 22:19:58 +0200
> Erik Blomqvist <erikblomqvist3 at> wrote:
> > Hi,
> >
> > I hope this is the right mailing list for this question. If nothing else
> you
> > seem to be the right people to ask.
> >
> > Considering that dash and mawk are smaller and faster than bash and gawk
> I
> > was a bit surprised to find that LFS doesn't support them. Even Ubuntu,
> that
> > is a huge distribution by comparison, uses those packages because they
> > provide better performance. Considering that one of the reasons for
> building
> > your own linux system is to get better performance, it would make sense
> to
> > use the best performing packages. So why doesn't LFS use or at least
> support
> > these packages?
> >
> > I'm specifically interested in knowing if there are any technical reasons
> > for not supporting these packages, e.g. package x doesn't work with
> > dash/mawk. If it's just for historical reasons, maybe it's time to
> > reconsider?
> >
> I don't know about mawk as I've not tried it, but dash is not hard to
> live with. Glibc needs a sed to a Makefile
> sed -i 's/ot \$/ot:\n\ttouch $@\n$/;s:) $(SHELL):) bash:' manual/Makefile
> Beyond that there are some strange problems where the configure script
> tests the shell that it's running in and assumes that it is /bin/sh. So
> if you're logged in to a bash session but /bin/sh is pointing at dash
> the Makefiles assume /bin/sh is bash and then fail with errors because
> dash doesn't support += syntax. See
> Andy
> --

dash is in blfs,  and back about 3 years ago, worked with all the packages I
used (think there was a patch I wrote up, to make java depend use
#!/bin/bash in their script).

bootscripts have changed little, and they support dash.

Nathan Coulson (conathan)
Location: British Columbia, Canada
Timezone: PST (-8)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the lfs-dev mailing list