glibc issues with --enable-kernel=

Matthew Burgess matthew at
Fri Jan 21 14:27:57 PST 2011

On Fri, 21 Jan 2011 15:48:09 -0600, Bruce Dubbs <bruce.dubbs at> wrote:
> OK, so do we use (LFS-6.5)?  Do we need to update any other
> packages in the requirements or make everything from LFS-6.5 (Aug 2009)?
>   Right now, the minimum requirements are from LFS-6.3 (Aug 2007).

If we set it to 2.6.30 (there's no point in adding the stable version as
Glibc only checks the major.minor.patch level), we'll miss out on
F_GETOWN_EX (new in 2.6.32 - see and
recvmmsg (new in 2.6.33 - see support.

Release dates of those kernels are as follows:

2.6.30 - 10-Jun-2009
2.6.32 - 03-Dec-2009
2.6.33 - 24-Feb-2010

So, by the time LFS-6.8 is released, 2.6.33 will have been out for just over
12 months.  Given that most major distros have moved to a 6-month release
cycle, and that LFS-6.7 also meets that dependency, I don't think it's an
overly hard-to-meet requirement, so I propose bumping it straight up to



More information about the lfs-dev mailing list