glibc issues with --enable-kernel=2.6.22.5

Gilles Espinasse g.esp at free.fr
Fri Jan 21 12:39:38 PST 2011


----- Original Message ----- 
From: "Matthew Burgess" <matthew at linuxfromscratch.org>
To: "LFS Developers Mailinglist" <lfs-dev at linuxfromscratch.org>
Sent: Friday, January 21, 2011 8:38 PM
Subject: Re: glibc issues with --enable-kernel=2.6.22.5


> On Fri, 21 Jan 2011 12:13:21 -0600, Bruce Dubbs <bruce.dubbs at gmail.com>
wrote:
> > Matthew Burgess wrote:
> >> On Fri, 21 Jan 2011 11:32:34 -0600, Bruce Dubbs <bruce.dubbs at gmail.com>
> > wrote:
> >>
> >>> In any case, should we change the book to update the glibc kernel
> > option to 2.6.30?  I don't know if a similar change to the host system
> >>> prerequisites is also needed or not.

Kernel running on host is mandatory more recent|equal than --enable-kernel
value.
Or glibc will simply not build with 'FATAL: kernel too old' error message
Fail for me at 2/3 of the build log size in sunrpc

Gilles




More information about the lfs-dev mailing list