glibc issues with --enable-kernel=2.6.22.5

Matthew Burgess matthew at linuxfromscratch.org
Fri Jan 21 09:49:45 PST 2011


On Fri, 21 Jan 2011 11:32:34 -0600, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:

> In any case, should we change the book to update the glibc kernel option
>   to 2.6.30?  I don't know if a similar change to the host system
> prerequisites is also needed or not.

I think we'd be wise to update the host system prerequisites.  My understanding
is that the --enable-kernel= will cause Glibc to omit fallbacks for kernels
older than that.  That could mean that any programs we build against that Glibc
will fail if the host system isn't at the specified version of the kernel or
newer.  At the very least, we'd have to state that the tests depend on the
version of the host system's kernel.

Regards,

Matt.




More information about the lfs-dev mailing list