kernel > 2.6.36 and ntfs-3g mce-error

Andrew Benton b3nton at gmail.com
Tue Jan 18 09:17:44 PST 2011


On Tue, 18 Jan 2011 12:13:01 +0100 (CET)
Sven Goericke <sgoericke at vandalay.org> wrote:

> Hi,
> 
> i've built the lfs-svn version from december 23th with the latest 2.6.36 Kernel.
> The system runs well until i installed ntfs-3g and mounted a NTFS-partiton.
> 
> Mounting the partition, after vew minutes (approx. 2 or 3) the system freezes
> (the screen blanks and doesn't respond even to magic sysrequest). After reset
> on the next reboot the following message appears:
> 
> lfs-kernel: HARDWARE ERROR
> lfs-kernel: No human readable MCE decoding support on this CPU type.
> lfs-kernel: Run the message through 'mcelog --ascii' to decode.
> 
> However, there are two strange things: first: the message appears 6 times, but
> i've a quad-core Intel Q9550 (no hyperthreading). Second: in oppose to other
> reports i found with google related to this error, the Kernel keep running
> after that message (no panic). And until i mount the NTFS-Partition, all
> works well.
> 
> With google i found only one hint (and in german) in a Ubuntu-forum. 
> http://forum.ubuntuusers.de/topic/kernel-panics-ohne-erkennbares-muster/?highlight=flash#post-2466827
> 
> The problem reported is similar to mine: after installing nts-3g and mounting
> a NTFS-Partition the system freezes and give the same error on next reboot.
> 
> I decided to rebuild the LFS-System again using the latest svn-version but
> with the latest 2.6.35 Kernel. No problems with that, the system runs very
> well and stable.
> 
> I'm a C/C++ programmer but no kernel-hacker so i didn't try to track down
> the problem. Maybe one of you is able to check/reproduce the problem?
> 
> Some information about my hardware:
> 
> Mainboard: Asus P5QD Turbo (all oc-features etc. disabled in BIOS, not needed :) )
> CPU: Intel Core2Quad Q9550 stock-speed 2.83GHz C1 stepping
> RAM: 8GB
> Graphics: EVGA Nvidia GTX470
> HDD: 4x500GB
> Sound: Creative Xfi Titanium PCIe
> 
> The system is compiled as 32bit i686, Kernel with PAE and HighMem 64G compiled.
> No modules, all compiled in (except one module called scsi_wait.ko and
> the Nvidia-driver)
> -- 
I also use ntfs-3g to mount my windows partitions. It does occasionally
give me problems (if I do mount -a it will sometimes complain "device
or resource busy") but nothing as alarming as the system freezing like
you describe. I also have a Q9550 but I use an ATI graphics card with
open source drivers. I would suggest that you try narrowing down what
is causing the problem by using the open source Nouveau drivers and try
mounting the partition with the kernel's read only ntfs driver. Also,
have you tried rebooting into windows and fscking the partition?

Andy



More information about the lfs-dev mailing list