pkg-config problem

Matthew Burgess matthew at
Sun Sep 19 15:06:10 PDT 2010

On Sun, 19 Sep 2010 22:30:46 +0100, Ken Moffat <ken at> wrote:
> On Sun, Sep 19, 2010 at 02:56:08PM -0600, Matthew Burgess wrote:
>> On Fri, 3 Sep 2010 19:28:26 +0100, Ken Moffat <ken at>
> wrote:
>> > sed -i -e '/^_PKG_TEXT/s/dnl/[]dnl/' \
>> >        -e '/^To get/s/dnl/[]dnl/' pkg.m4
>> > 
>> > will do it, for those who dislike patching.  The simple "change
>> > '])dnl'" version I tried also changed other lines.
>> It turns out that this was actually a bug in Autoconf, not in
> pkg-config.
>> See
> and
>> for the upstream details.
>  Odd, I thought the match that google found was reported to
> autoconf, and deemed to be a pkg-config issue.
>> Sadly, I caught this too late for 6.7, oh well!
>> Here's the sed that'll achieve the same as the upstream fix (minus their
>> test suite addition, of course):
>> sed -i -e 's/])m4_defun/[]&/' lib/m4sugar/m4sugar.m4
>> Ken, what package was it you were updating that tickled this bug?  I'll
>> try to reproduce and confirm the fix before commiting this one to the
> book.
>  nfs-utils-1.2.2 : there is a patch from gentoo -
> which has an explanation of the required autofoo.  If you get a
> successful completion, with an updated 'configure' script, the
> alternative fix has worked.

Thanks again Ken.  I've now confirmed that removing the pkg-config
sed, and using the autoconf sed above results in the nfs-utils configure
script regenerating correctly.  Looks like the fix is good.

Bruce, I think it would be worth adding an errata, although given the
relatively few packages that require running the autotools to regenerate
their configure scripts, I think it's unlikely to bite too many people too



More information about the lfs-dev mailing list