perl segmentation fault

Matthew Burgess matthew at linuxfromscratch.org
Mon Aug 3 13:25:35 PDT 2009


On Mon, 03 Aug 2009 22:15:46 +0200, Tobias Gasser <lfs at ebp-gasser.ch> wrote:
> Tobias Gasser schrieb:
>> the following sefaults (i've rebuild the book on a second machine with
>> the same result!)
> 
> meanwhile my second machine has rebuild from scratch and reached the
> perl script.
> 
> the last builds i omitted the test suites. this time i run the test for
> perl and get 108 out of 1288 failed tests.

Tobias, I cannot reproduce this here.  My original logs don't show any errors
in the test suites.  I've since installed several Perl modules (without
using CPAN) including some compression stuff, so simply removed /usr/lib/perl5,
rebuilt Perl by the book, and reinstalled it.

Again, the CPAN shell behaves itself fine.  Have you perhaps done something
really aggressive with optimisation settings or maybe run 'strip --strip-all'
on libraries?

What does 'strings /usr/lib/zlib.so | grep -i zlibVersion' output for you?

On mine I get 'zlibVersion', as expected.

A rebuild of zlib might get things working for you again.

Regards,

Matt.




More information about the lfs-dev mailing list