Shadows 'groupmems' program segfaults

Robert Connolly robert at
Sun Oct 12 09:43:41 PDT 2008

On Sunday October 12 2008 12:13:24 pm Randy McMurchy wrote:
> Hi all,
> I don't consider this a big issue, but want to throw it out there.
> I noticed when I ran the new Shadow 'groupmems' program, it segfaults.
> I didn't think to much about it at the time as this program is new
> to Shadow and the man page says you must create a special group and
> set the program with GID permissions (2775) which I didn't do.
> However, looking at the console, I see the actual errors produced by
> the segfault. Wondering if anyone can make anything from this:
> groupmems[13783]: segfault at 72657375 ip b7feb18b sp bf8eac2c error 4 in
>[b7f79000+13a000] groupmems[13823]: segfault at 72657375 ip
> b7fa118b sp bfea11dc error 4 in[b7f2f000+13a000]
> groupmems[13824]: segfault at c ip 0804975f sp bfbb6780 error 4 in
> groupmems[8048000+5000]

As root, I tried every 'groupmems' option, and they all work. I'm using 
shadow-, glibc-2.8-20080908, binutils-, and 

A segfault in 'groupmems' was reported at Debian, and fixed in shadow-
I do get a segfault if I use a group name that doesn't exist (reported at 
Gentoo, not yet fixed from what I see).

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <>

More information about the lfs-dev mailing list