Perl error

Tobias Gasser lfs at ebp-gasser.ch
Sat Nov 15 05:42:47 PST 2008


Gilles Espinasse schrieb:
> You have written
>> i really have no clue what happens. possibly missing a library, but i
>> can't see which and/or why. i'm shure to have followed the book except
>> CFLAGS="-O3 -march=i486"
> 
> perl understand your arch as i686.
> What is the result if you remove your custom CFLAGS?

same result. i tried 3 times, and each started compiling without 
rebuilding the dependencies and failing on linking miniperl.


> Did you test with -Darchname=i486-linux in configure script when
> using -march=i486?

same result (again, 3 times, 3 failures).
with CFLAGS="-O3 -march=i486"
and the options as mentionned in the book plus -Darchname=i486-linux


> Not sure the two are strictly related but on ipcop, we build for x86
> perl-5.8.8 with
> CFLAGS="-Os -fomit-frame-pointer -march=i486 -mtune=pentium -pipe"
> and configure.gnu script with -Darchname=i486-linux  (and other parameters)
> and it work.

i tried adding mtune: CFLAGS="-O3 -march=i486 -mtune=pentium".
3 failures without -Darchname, 3 failures with -Darchname.

as all above test failed, i retried the same script as i used for my 
successfull nightly build. 1 failure, the second was successfull!!


i never had any problems with older perl builds following the book. the 
machine is about 3 years old and i've built at least 6 complete lfs 
systems with it, using the resulting disks in older system as firewalls, 
file-, web- and mailservers. always with CFLAGS="-O3 -march=i486"

my next issues for next week will be:

1) try the job on an other machine

2) try to install spamassassin on the current machine despite the 
failures in test. this will load a bunch of sources from cpan, probably 
failing. if this is successfull and step 1 fails too, i guess i'l live 
with the strange behaviour.



thanks for your help
tobias



More information about the lfs-dev mailing list