As promised: LFS compilation summary

Philipp Christian Loewner bOrgph at web.de
Thu May 8 15:02:07 PDT 2008


Hi everyone!

After completing my school's final
exams, I found time to do the LFS build.
Here is a quick summary:

I used the development LFS book version 20080423
but the newest available packages.

As for the system specs, it is a 32bit system running
the actual LFS live CD at build time.
I don't think any other information is relevant
here.

For using GCC-4.3.0, I first hab to install
GMP-4.2.2 to / and then MPFR-2.3.1 to / using
--with-gmp=/ as configure option.

I used CFLAGS -pipe -O2 -m32 -march=pentium-m
and the same for CXXFLAGS and CPPFLAGS (as it
seems unclear sometimes which variable is used).

Before doing the first installation (binutils),
I installed GMP and MPFR into the /tools directory,
too because the GCC bootstrap seemed to get into
trouble in the second stage without them.
I ran the testsuites for both of them as
according to the website, especially GMP is
known to trigger some bugs in some GCC versions.
The testsuites ran just fine.

As not told otherwise, packets are installed with
version numbers and commands used in the book.

GCC-4.3.0
	- configure: --with-gmp=/tools --with-mpfr=/tools
	(Perhaps this renders the installations in /
	obsolete, but I haven't tried out yet.)
	- configure: Throws warning of configuration
	not supported in some subdirectories.
	Libstdc++ was among them, but there was no
	trouble building anything the whole book.
	- make: The build time was very short. I
	didn't look it up but it could be that the
	bootstrap is not automatically performed
	with GCC-4.3.0 anymore.
linux-2.6.25.1 headers
	No problems.
Glibc-2.7
	Does not compile with GCC-4.3.0 by default.
	I found some patches searching the web, though.
	If you ask, I'll send them but for the moment
	they don't seem to belong in here.
	I changed the configparms editing command
	according to my CFLAGS.
GCC-4.3.0
	Everything the same as the first time.

Coreutils-6.11
	Used newer version. Runs without complaining.
e2fsprogs-1.40.9
	Dito.
findutils-4.4.0
	Dito.
perl-5.10.0
	I used the 5.8.8 patches. Compiled without
	complaining, alltgough I'm sure it had problems
	on a 64 bit system. Perhaps I just messed
	something up there.
tar-1.20
	No problems.
util-linux-ng-2.13.1.1
	Dito.

OK this was the initial toolchain. For the final system,
I installed GMP and MPFR first, this time to /usr.
GCC-4.3.0 required m4, so I installed it first
(version 1.4.11)

I DID NOT run the testsuites, even if they are
considered critical because I did not
install Tcl, expect and DejaGNU.

BUT: I did run the perl testsuite. There was
one test failing, namely setlogsock(), but
this method seems deprecated anyway according
to the perl documentation, so I ignored it.

for zLib-1.2.3, I temporary added -fPIC to
my CFLAGS.

There are newer versions of GRUB available, but
due to me lacking documentation reading support at
the moment of installing, I preffered 0.97.

groff-1.19.2
	I know there is no patch. Didn't care.

IPRoute2-2.6.25
	No problems.

man-db-2.5.2
	configure: Complains about missing
	groff patch. Ignored.

texinfo-4.12
	No problems.


First I had installed udev-120 but my system didn't
boot. It turned out to be a problem due to missing
kernel features, but I didn't recompile 120 after
I had installed 113 then.
Perhaps a hint in the book saying which kernel
features to enable (e.g. Unix domain socket) to be
able to boot at all would be good in the book...
I stumbled across these problems a few times now,
always enabling randon kernel features und deleting
them one-by-one, rebooting... until I have all the
features I need.
I don't think of a kernel features compendium,
just some short side note or something.


The next in row is going to be a busy box, but I'm
still struggling with the network card drivers there.
Don't know what I'm doing wrong there, but I'll do a
few things to enhace this build log then (e.g. gcc
testsuite etc). The whole thing will take some time
(AMD K6-2) but if you still want, I'll send you something
similar to this log when done.

Thanks for your time..
	- Philipp



More information about the lfs-dev mailing list