udev in chroot

Jacek Herold jherold at interia.pl
Fri Jan 25 00:24:31 PST 2008


Hello Bryan,

Friday, January 25, 2008, 2:10:20 AM, you wrote:

BK> -----BEGIN PGP SIGNED MESSAGE-----
BK> Hash: RIPEMD160

BK> Jacek Herold wrote:
>> I'm trying to change to the chroot environment. When starting udev 
>> (in the chroot environment) i have the following error:

BK> The book doesn't start udev in the chroot environment (...does it?), for
BK> exactly this reason.  I'm surprised it worked at all with earlier
BK> kernels -- although I would suspect that it may have worked with earlier
BK> udev versions.

BK> (This is something we still need to figure out regarding the udev
BK> persistent-net support, too: writing the udev rules doesn't work anymore
BK> unless udev is running, and it's never running until after the target
BK> system boots.  That's too late to generate the rules, because the user
BK> has to configure the NIC in chapter 7.)

BK> Unless earlier book versions ever started udev inside chroot?  I don't
BK> think so, but they might have...

BK> (If you want udev to manage your /dev while you're in chroot, you can
BK> bind-mount the host's /dev and use its udev, instead of running two udev
BK> processes.)
BK> -----BEGIN PGP SIGNATURE-----
BK> Version: GnuPG v1.4.7 (GNU/Linux)
BK> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

BK> iD8DBQFHmTb7S5vET1Wea5wRA7evAKCA9Vtv9bbFcVf3rCv4HwOogrFH0ACgqB2R
BK> Jg2JYiDWxZeHpuXXTYhaf/s=
BK> =rPEE
BK> -----END PGP SIGNATURE-----

I was trying to move the whole system to RAM then remove the boot hard
drive - just for some researches :). In earlier system it was not a
problem to have two udev working - second in chroot (somehow). I can't
use the bind-mount.

Is it possible to create device files in chroot /dev without using
bind-mounts?

-- 
Pozdrawiam,
 Jacek                            mailto:jherold at interia.pl



----------------------------------------------------------------------
Sprawdz, ktore komorki sa najmodniejsze!
Kliknij >>> http://link.interia.pl/f1cd4




More information about the lfs-dev mailing list