Glibc-2.7: awk should be gawk, not mawk

Petr Ovtchenkov ptr at island.corbina.net
Mon Jan 14 20:45:58 PST 2008


On Tuesday 15 January 2008 01:59, Bruce Dubbs wrote:
> Petr Ovtchenkov wrote:
> > Hi,
> > 
> > I want to add my 2 cents to LFS.
> > 
> > Note to http://www.linuxfromscratch.org/lfs/view/development/chapter05/glibc.html
> > (5.6. Glibc-2.7):
> > 
> > Pay attention what is awk; if this is link to mawk (not gawk), then probably
> > you will have problem with glibc-2.7 building.
> 
> Look at the preface to the book:
> 
> http://www.linuxfromscratch.org/lfs/view/development/prologue/hostreqs.html
> 
> It clearly says that gawk is required and provides a test for it.

Yes, I see. My problem was: Kubuntu has both gawk and mawk, and awk -> mawk.
So test should check as 'gawk' as 'awk'.

  - ptr



More information about the lfs-dev mailing list