udevid segfaulting

Bryan Kadzban bryan at kadzban.is-a-geek.net
Sun Oct 28 04:55:59 PDT 2007

Hash: RIPEMD160

Bruce Dubbs wrote:
> Bruce Dubbs wrote:
>> I tried to patch udev116 with this and it didn't work.  I did a 
>> cut/paste of the patch to a file, but only the first segment
>> applied. The other three rejected.
>> Is there something different about this patch format?  I can
>> generate the patch without too much problem, but I wonder why the
>> cut/paste doesn't work.
> Never mind.  In the git generated file are constructs like:
> @@ -224,8 +222,6 @@ static int usb_id(const char *devpath)
> It should just be:
> @@ -224,8 +222,6 @@
> The annotation with the function name on the line seems to confuse
> patch.

That's odd; I was generating patches that had that field in them a few
days ago (via "diff -Npru"), and patch (2.5.9) seemed to handle them
fine.  But I just tried this one (again, patch-2.5.9), and you're right,
it chokes.  Maybe if you add -p and -u to the diff options and remove
- --git, and kill the "index" line?

You might also try this URL:


since the HTML generator may have hosed up something?

Or just kill the function names; that's probably the simplest.
Version: GnuPG v1.4.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the lfs-dev mailing list