FAQ bit rot

Luca liliana.perossa at fastwebnet.it
Wed Jan 31 07:04:02 PST 2007

Alexander E. Patrakov ha scritto:
> Luca wrote:
>> In Faq, point General compilation errors there's a "Glibc compilation
>> errors out due to a missing nss.h header file".
>> Following the link points to:
>> Glibc compilation errors out due to a missing nss.h header file
>>     This usually indicates that you are compiling LFS onto a Reiser4
>> partition. Unfortunately, there is currently no known solution, other
>> than to use a different type of filesystem.
> Just in order to test this, I created a VMware virtual machine (based on LFS 
> LiveCD 6.2-5) on ums.usu.ru. The virtual disk is formatted as reiser4. Let 
> jhalfs run for the night, and tomorrow I'll see if this FAQ item is valid.
> 1) the NASM requirement for LILO (mentioned in the FAQ) is no longer valid.
> 2) The locale example in the "Why does less (and therefore man) print <AD> 
> instead of hyphens?" item is horribly wrong.
> 3) "Glibc fails and mentions BEGIN and END" mentions static linking, which 
> applies to the old book only, and only confuses the reader who doesn't know 
> all the LFS history.
> 4) "... it is normal to compile GNU libc with the `linuxthreads' add-on..." 
> - again, old book.
> So there is enough bit rot :(
>> Actually this answer is not fully correct. It's possible to compile LFS
>> natively on a Reiser4 partition at some extra costs:
>> Host system should support Reiser4 file-system (latest official patch
>> for Reiser4 is for linux kernel, in case booting with grub of
>> host-system, libaal, reiser4progs and libreiser4 must be installed, grub
>> must be re-installed after patching it to support Reiser4 (patch found
>> at official NAMESYS site), reiser4progs needed, if a Reiser4 partition
>> was created with mkfs.reiser4 version < 1.0.0, must be run
>> debugfs.reiser4 -C device, fsck.reiser4 device.
> Let's hope that the only incorrect bit above is that the reiser4 patch 
> works. The fact is that it causes unacceptable regression for all other 
> filesystems (that's why I had to release LFS LiveCD 6.2-5). The "fix" is to 
> set CFLAGS to "-O0" or "-O1" while compiling GRUB.
Hi Alex.

Well, at that time I used this way to build LFS natively on reiser4, not 
virtualizing or whatever else; I added support for Reiser4 in the 
host-system and formatted lfs-partition to reiser4. Then started 
building there and everything worked; then just to be sure, since I had 
some extra unused space on disk, I booted lfs-reiser4 with its own grub 
(compiled with CFLAGS set to "-00") created the reiser4 partition from 
there and installed a new lfs all (host and new lfs) on reiser4 and 
everything worked without errors.


More information about the lfs-dev mailing list