LFS LiveCDs 6.2-4 - grub-install problems. (util-linux-2.12r?)

Piet Delaney piet at bluelane.com
Fri Jan 26 18:29:07 PST 2007

Alexander E. Patrakov wrote:

> Piet Delaney wrote:
>> Any chance on fixing this on the iso. We are useing it as a starting
>> point for our installation. Bringing our own grub is a possability
>> but being as it's got files and all it seems better to fix the iso image.
> The problem is that a fully-working fix is not identified yet, except
> dropping the reiser4 patch completely. Once this is resolved, a new ISO
> will appear.

Hey Alex:

Looks like you right about grub being the cause of the 1st problem.

> 2. The second problem is that once a kernel is running that it can't open
> the root filesystem. It's not just a kernel problem, as even
> kernels more recent than the 2.6.16 kernel (2.6.18 for example)
> also fail to boot.

It turns out to also be the cause of the 2nd problem. Our code is
based on LFS 6.1 and I tried including a static copy or our grub-0.95
version with our install files. It now installs fine. Not sure if 
it's worth while to include the other grub files. Perhaps even cleaner
would be getting the src of the new grub that comes in LFS 6.2, compiling
that -O0 like you did and using that.

I hit an unexpected problem while I linked our old 6.1 grub static. 
When I ran 'configure' with arg LDFLAGS=-static and it build fine.
Unfortunately in my complete build it broke because stage1 and 
stage2 weren't installed in:


Probably by the time you back online I'll have figured out why this
happen. If anyone happens to know why such an odd thing should occure
you might as well post a followup in case I haven't figured it out yet.

Fortunately I'm not hitting Sami Tarazi problem with udev. Perhaps that's
only a problem with the 6.2-4 ISO; my success with with the 6.2-3 iso.

Anyway, thanks for the tip; your too Sami.


More information about the lfs-dev mailing list