thorsten fly_b747 at gmx.de
Tue Oct 31 09:59:27 PST 2006

This is a possible bug report for the bootscripts 6.2:

What I was trying to do: Have two Instances of openvpn running at the
same time, beeing started and stopped separately by two scripts in
/etc/rc.d/init.d. I called them with:
loadproc -p /var/run/openvpn-1.pid openvpn --config someconfig1 and
loadproc -p /var/run/openvpn-2.pid openvpn --config someconfig2.

And tried to stop them with
killproc -p /var/run/openvpn-1.pid openvpn and
killproc -p /var/run/openvpn-2.pid openvpn respectively.

When both instances are up and I tried to stop one of both, the right
openvpn process gets killed and the pidfile removed but the script
reports a [failed] due to the fact that pidofproc one time gets called
without the -p option. I tried to correct it with the appended patch. I
also tried to correct a message generated by kill "no such process",
which should go to /dev/null I guess.

I hope this helps, regards thorsten
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: functions.patch
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-dev/attachments/20061031/b726b0fa/attachment.ksh>

More information about the lfs-dev mailing list