cross sparc64 chapter 5 glibc tls required error with 20050930 version of book

Frans Verstegen frans_verstegen at yahoo.fr
Sat Oct 1 01:17:51 PDT 2005


I'm afraid I'm overlooking something obvious, I still get the same
error following the "Version 7.0-cross-lfs-20050930-Sparc64" book.

>From configure:
  (...nothing suspicious before...)
  checking for long double... no
  checking size of long double... 0
  running configure fragment for sysdeps/sparc/sparc64/elf
  checking for sparc64 TLS support... no
  checking for sparc64 ld WDISP22 handling... ok
  running configure fragment for libidn/sysdeps/unix
  running configure fragment for nptl/sysdeps/unix/sysv/linux
  running configure fragment for nptl/sysdeps/pthread
  checking for forced unwind support... (cached) yes
  checking for C cleanup handling... (cached) yes
  running configure fragment for sysdeps/pthread
  (...nothing suspicious here neither...)

Then make aborts with
  In file included from include/tls.h:6,
                   from <stdin>:1:
  nptl/sysdeps/sparc/tls.h:59:3: error: #error "TLS support is
required."
  make[1]: *** [/mnt/LFS-6/build/glibc-build/Versions.v.i] Error 1
  make[1]: Leaving directory `/mnt/LFS-6/build/glibc-20050926'
  make: *** [all] Error 2

The reason seems to be that the crt1.o file is not found by the linker
while running the test fragment.



I can work around this by forcing tls support in the config.cache file:
  libc_cv_sparc64_tls=yes
Then configure goes like this:
  (...)
  running configure fragment for sysdeps/sparc/sparc64/elf
  checking for sparc64 TLS support... (cached) yes
  checking for sparc64 ld WDISP22 handling... ok
  (...)

And then the build completes without error.
Is this the way to go ?

Frans




	

	
		
___________________________________________________________________________ 
Appel audio GRATUIT partout dans le monde avec le nouveau Yahoo! Messenger 
Téléchargez cette version sur http://fr.messenger.yahoo.com



More information about the lfs-dev mailing list