flex-2.5.31

David Jensen djensen at inebraska.com
Fri Jun 3 06:29:45 PDT 2005


I poked at this for a couple days, and there are problems with the 
current flex build instructions:

1.  The order of the files in flex-2.5.31-debian_fixes-2.patch may 
sometimes trigger regenerating scan.c, which causes the build to fail if 
flex is not already installed.
-- Solution:  Move the scan.c section of the patch to after the scan.l 
section. Build and install per the current instructions.  Goto 2.

2.  Now there is a flex installed but it does not incorporate the 
patched scan.l and flex.skl.
-- Solution: touch scan.l flex.skl; ./configure --prefix=/usr; make; 
make install.  the ./configure, again, is required to pick up the newly 
installed flex, else scan.c is destroyed and it bombs.

3.  The flex++ link has not been created since the switch to 2.5.31.  I 
didn't miss it in nearly a year, but maybe it is supposed to be there.
-- Solution: ln -s flex++ /usr/bin/flex

I could file a bug.
David Jensen




More information about the lfs-dev mailing list