Issue with PCH and 2.6.12 kernel

Greg Schafer gschafer at zip.com.au
Tue Aug 2 16:54:02 PDT 2005


Greg Schafer wrote:

> This should hopefully go onto the 3.4 branch soon.. which of course
> means it'll be in 3.4.5. We can always backport it to 3.4.4 if
> deemed necessary.

Here is the final patch as committed:

  http://gcc.gnu.org/ml/gcc-cvs/2005-08/msg00052.html

In summary, if you need working precompiled headers when running
linux-kernel-2.6.12 or above, you must do at least 1 of the below:

 - backport above patch to 3.4.4
 - use a 3.4.5 snapshot
 - use 4.0.x
 - echo 0 > /proc/sys/kernel/randomize_va_space
     (or use sysctl to achieve same)

Regards
Greg
--
http://www.diy-linux.org/




More information about the lfs-dev mailing list