Posix Patches -- Cross-LFS Branch

Jim Gifford lfs at jg555.com
Fri Apr 22 17:32:33 PDT 2005


I was working on the cross-lfs branch and I stumbled onto a possible 
scenario.

As we know there are two packages in LFS that suffer the SuS V3 
incompatibilies, I'm not sure of any distro's out there that are not 
setting the coreutils to build to it's current POSIX level, but what if 
one did.

Should we start including the patches for binutils and gcc to prevent a 
possible error, or add it as an optional patch if a certain criteria 
fails, or should we not worry about it.

Should we add this to the current branches besides cross-lfs, like 
multi-arch, and unstable.

My vote is just add the patch, since it doesn't effect anything, but 
possibly avoids the issue. Then we can get rid of setting the coreutils 
POSIX level, since most packages have fixed this issue.

I will leave it up to the community and my fellow developers to decide, 
but we do need to hear your feedback.

-- 
------
jim at linuxfromscratch.org
lfs at jg555.com

LFS User # 2577
Registered Linux User # 299986




More information about the lfs-dev mailing list