gcc 2.95

Jeremy Huntwork jhuntwork at linuxfromscratch.org
Mon Aug 2 10:54:33 PDT 2004


On Mon, 2004-08-02 at 19:46 +0200, Laurens Blankers wrote:
> Hi all,
> 
> I see the testing branch no longer uses the gcc 2.95 compiler to compile 
> the kernel because of problems with NPTL. However some kernel extensions 
> only compile with 2.95 (e.g. http://l7-filter.sf.net/).
> 
> Will compiling with 2.95 just fail the testsuite, or will something more 
> serious go wrong?
> 
> I read a post some time ago about the glibc testsuite failing when the 
> running under a non-NPTL kernel such as 2.4. Is this the same issue?

Laurens,

IIRC, it is still considered safe to continue building LFS, even though
glibc's testsuites have failed due to a 2.6 kernel compiled with gcc
2.95.

-- 
Jeremy Huntwork
http://www.jenacon.net




More information about the lfs-dev mailing list