Perl doesn't configure properly, help?????

Luke Guest lguest at
Fri Oct 11 07:11:39 PDT 2002

Damian Wojslaw wrote:

>> Like I said at the bottom of my previous post, I wasn't getting any help
>> there. I thought that the developers may have come across the problem and
>> know a way of fixing it?
>> Luke.
> 'lo. I'll answer, since I've just recently solved my own perl
> compilation problem. The lone mad 0 was, in my case, the result of
> improperly created /dev/random. Check if your /dev/random
> looks like this:
> crw-rw-rw- 1 root root  1, 8 Oct 6 13:06 /dev/random
> In my case it was malformed. I had two file /dev/random and
> /dev/random. None of them was a proper /dev/random node. I have deleted
> both and recreated it with mknode c /dev/random 1 8. It not only solved
> problem with this 0, but also solved problem when perl compilation stopped
> somwhere in x2p.
> Cheers

Thanks. Now, I'm not doing the MAKEDEVICES step, that could be a problem - 
hmmm, I'll have to make a dummy one then remove it afterwards ready for 
when I've got defs working ;-)

This should go into the book at that step.

Thanks again,

P.S: I knew it was worth posting to this group!! ;-P
Unsubscribe: send email to listar at
and put 'unsubscribe lfs-dev' in the subject header of the message

More information about the lfs-dev mailing list