warning: pointer of type `void *' used in arithmetic

Erika Pacholleck pchllck at nexgo.de
Thu Jul 4 02:47:47 PDT 2002


[03.07.2002] jsmaby at virgo.umeche.maine.edu <-- :
> Using 'pwd.lock' sounds a little better to me than 'pwd.lck', which
> I tend to pronounce as pea double you dot lick, which just sounds
> disturbing, but if you're a three letter suffix kinda person (old
> habbits die hard), then .lck would work just as well.

No, I am not and usually I tend to call files long format, just to
make sure they are not missunderstood, so my first preference would
have been passwd.lock. The reason behind this was:

1. if it is in a /lock directory it is clear that's a lock file
   analog my syslog files are simply called /var/log/<facility>
2. FHS mentions the device locking file to be LCK..<device>
   not to break more than necessary and stay near to the original
   LCK..device = device lock
   program.lck = program lock

But more important here, sorry I did not see that in first instance,
is that we are not precice! Due to the rule, name the child, we
should really call the lockfile **passwd**. If we follow glibc
naming and later look into /var/lock/ and find a pwd.xx we might ask,
"Why the heck do we have a lock file for pwd, pwd is simply for the
current dir, so what reason to lock it??"

Most important is to know where to find it (and for me non-programmer
the unlink *g* ). In the end we will decide for our own anyways,
won't we?
-- 
Erika ...---...: pacholleck at nexgo dot de
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list