Install-Report (LONG)

Gerard Beekmans gerard at
Fri Jun 30 13:27:36 PDT 2000

> First "problem" I encountered was in "Compiler optimization". I was not
> able to find possible cpu-identifiers. Of course the example i686 worked,
> but I was courious about other possibilities...

The GCC info page has the options you can use. To summarize: i386, i486,
i586 and i686 are the ones you can use (or use pentium (which is the
same as i585) and pentiumpro (which is the same as i686)).
> 	file - login only by ftp-client (not with my netscape)?

As told before. that ftp server can't use PASSIVE mode which Netscape
uses and can't be disabled AFAIK. A regular ftp-client can be configured
to use or not to use PASSIVE mode (the ftp from netkit-ftp has it
disabled by default).

> Starting to compile the first things I thought if Gerard sends all the
> patches he (?) did to the packages to the actual maintainer of the 
> packages [Now I know he wants to, but keeps forgetting :)]

Yeah tell everybody about it. Now everybody knows about my awesome
> "Installing Glibc" - Why do I have to copy the archives into the
> unpacked glibc-dir? I just unpacked them there...

It was to be more consistent with chapter 2 which explains how and where
to unpack stuff. 

> A nice way to create configparms (and some other files) is to use
> cat, echo and such... If you add those commands to the script it's
> easier to cutnpaste :)
> 	balu at Balu:# cat >configparms 
> 	# Begin configparms
> 	slibdir=/lib
> 	sysconfdir=/etc
> 	# End configparms 
> 	<ctrl-d>

Looks good. I could add that yes.
> 	root at Balu: > ls /lib/libc*
> 	/lib/  /lib/
> 	root at Balu: rpm -q libc
> 	libc-2.1.3-58

A good distribution would show files like /lib/libc-2.1.3 and
should be symlinks to /lib/libc-2.1.3 (or whatever version is used)
> "Installing Gzip" - while trying to mv gunzip gzip $LFS/bin I got a gzip -
> file not found. Trying the same command again gave "gunzip not found".
> Dunno why this happened, but after that both files were in /bin.

I'm getting them too. 2.3.6 has the work around to just copy the two
files to /bin and then rm them from /usr/bin
> While configuring perl I was annoyed about answering all those questions.
> Gerard didn't know an easier way, but I figured out that you can
> 	# ./Configure -Dprefix=/usr -d
> It "Failed 13 test scripts out of 229, 94.32% okay."

Sounds pretty good (most scripts fail because the lack of networking at
that moment). I'm not sure if I want to include that in the book now
I've thought about it a bit more. Perl gives you the option to
configure things so I shouldn't take the chance away (i'd still add the
-Dprefix=/usr part. I could mention the use of '-d' to accept all
defaults. Or the user can read the README and INSTALL files to find it
> Net-tools still contains a bash-2.03 part and it asks for many questions
> while making... Perhaps add a note that the defaults are okay.

Not for me. I want it to have PPP enabled and I think it has it disabled
by default. Or was it PPP and SLIP enabled and I want to disable SLIP.
Either way the defaults aren't always good enough for everybody.
> While compiling the kernel don't use any modules! Even don't try to
> use the "loadable module support" - gives error on booting, because
> of missing module-dependencies and such - you need a modules.conf in
> /etc, I think...

That worked fine for me (enabling loadable module support). I use it and
I don't have an /etc/modules.conf

> PS: Those rc-scripts need a "status"-function to be LSB-compliant, correct?

Correct and it's already there. /etc/init.d/functions has the status
command and /etc/init.d/sysklogd has it implemented.

Gerard Beekmans

-*- If Linux doesn't have the solution, you have the wrong problem -*-
Mail archive:
IRC access: server: port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)

More information about the lfs-dev mailing list