GLIBC compile probs in 3.3.6

Seth W. Klein sklein at mint.net
Mon Jul 31 14:38:40 PDT 2000


Joe Weidenbach wrote:
> 
> Weird one -- it compiled fine on my other P2 - 400...
> 
> I tried with and without the patch (Got invalid char. 45 without).  I have
> tried re-getting the source, and it's just not working on this mobile P2-400.  I
> am currently running LFS 3.3.4, building a new partition with 3.3.6 so I can
> test a few things differently.  Any thoughts?
> 
> make  -C sunrpc others
> <....>

Same problem here. I've compiled glibc before with this system so
something must have changed.... I'm working on compiling it with the
options that worked before. On this Cyrix 686 133 it'll be a while....

Someone mentioned binutils. I did upgrade to 2.10 recently. Perhaps
i'll try downgrading....

Or perhaps i won't, because... The compile hasn't finished yet, but i
switched to a normal user and home directory for my test compiles and
it breezed through `make -c sunrpc others'! So, as a workaround, try
compiling as a normal user.

Here's a log of my debugging efforts anyway:

#tar xzvf packages/glibc-2.1.3.tar.gz
#cd glibc-2.1.3/
#tar xzvf ../packages/glibc-linuxthreads-2.1.3.tar.gz
#tar xzvf ../packages/glibc-crypt-2.1.3.tar.gz
#patch -Np1 -i ../packages/glibc-2.1.3.patch
#mkdir glibc-build
#cd glibc-build/
#vim configparms
#cat configparms
slibdir=/lib
sysconfdir=/etc
#../glibc-2.1.3/configure --prefix=/usr --enable-add-ons --with-headers=$LFS/usr/include
#make
.
.
.
.
/mnt/scratch/usr/src/glibc-build/elf/ld-linux.so.2 --library-path /mnt/scratch/usr/src/glibc-build:/mnt/scratch/usr/src/glibc-build/math:/mnt/scratch/usr/src/glibc-build/elf:/mnt/scratch/usr/src/glibc-build/nss:/mnt/scratch/usr/src/glibc-build/nis:/mnt/scratch/usr/src/glibc-build/db2:/mnt/scratch/usr/src/glibc-build/rt:/mnt/scratch/usr/src/glibc-build/resolv:/mnt/scratch/usr/src/glibc-build/linuxthreads /mnt/scratch/usr/src/glibc-build/sunrpc/rpcgen -Y `gcc -print-file-name=cpp | sed "s|/cpp$||"` -c rpcsvc/bootparam_prot.x -o /mnt/scratch/usr/src/glibc-build/sunrpc/xbootparam_prot.T
make[2]: *** [/mnt/scratch/usr/src/glibc-build/sunrpc/xbootparam_prot.stmp] Segmentation fault (core dumped)
make[2]: Leaving directory `/mnt/scratch/usr/src/glibc-2.1.3/sunrpc'
make[1]: *** [sunrpc/others] Error 2
make[1]: Leaving directory `/mnt/scratch/usr/src/glibc-2.1.3'
make: *** [all] Error 2
#cd ../glibc-2.1.3/sunrpc
#/mnt/scratch/usr/src/glibc-build/elf/ld-linux.so.2 --library-path /mnt/scratch/usr/src/glibc-build:/mnt/scratch/usr/src/glibc-build/math:/mnt/scratch/usr/src/glibc-build/elf:/mnt/scratch/usr/src/glibc-build/nss:/mnt/scratch/usr/src/glibc-build/nis:/mnt/scratch/usr/src/glibc-build/db2:/mnt/scratch/usr/src/glibc-build/rt:/mnt/scratch/usr/src/glibc-build/resolv:/mnt/scratch/usr/src/glibc-build/linuxthreads /mnt/scratch/usr/src/glibc-build/sunrpc/rpcgen -Y `gcc -print-file-name=cpp | sed "s|/cpp$||"` -c rpcsvc/bootparam_prot.x -o /mnt/scratch/usr/src/glibc-build/sunrpc/xbootparam_prot.T
Illegal variable name.
Segmentation fault (core dumped)
#gcc --version
2.95.2
#bash --version
GNU bash, version 2.03.0(1)-release (i586-pc-linux-gnu)
Copyright 1998 Free Software Foundation, Inc.
root:/mnt/scratch/usr/src/glibc-2.1.3/sunrpc#
#size --version
GNU size 2.10
Copyright 1997, 98, 99, 2000 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License.  This program has absolutely no warranty.
#echo $LFS
/mnt/scratch

/mnt/scratch/usr/src/glibc-build/elf/ld-linux.so.2 simply segfaults if
"-Y `gcc -print-file-name=cpp | sed "s|/cpp$||"`" is left out. Otherwise
it first prints "Illegal variable name." as seen above. It also segfaults
with no args.

This machine was running Redhat 5.1; i have since upgraded many of the
basic components including glibc. My command shell is tcsh 6.09.


cheers,
sklein
--
sklein at mint.net                          http://members.mint.net/sklein/
--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list