Glibc (another problem)

Eric A. Ayer mwalker at ee.pdx.edu
Thu Jul 27 23:21:01 PDT 2000


> I finally narrowed down the problem to the configparms file.  without the configparms file glibc compiles perfectly, but with it I get the following:
> 
> > make  -C debug subdir_lib
> > make[2]: Entering directory `/mnt/hdc5/usr/src/glibc-2.1.3/debug'
> > ../Makerules:622: *** multiple target patterns.  Stop.
> > make[2]: Leaving directory `/mnt/hdc5/usr/src/glibc-2.1.3/debug'
> > make[1]: *** [debug/subdir_lib] Error 2
> > make[1]: Leaving directory `/mnt/hdc5/usr/src/glibc-2.1.3'
> > make: *** [all] Error 2
> 
> I have checked my configparms file repeatedly, and can not find anything different about it from the one in LFS2.3.6.  Any ideas on what could be wrong, or how I could get the equivalent  effect without using configparms?

I have had the exact same problem, and fixed it the exact same way (and posted
a message here, but that was a while ago).  In the documentation for glibc, it
says that just using --prefix=/usr will cause the files to be laid out the way
Linux wants them.  I *believe* that configparms is unnecesssary, and I have
worked on a lot of computers with it, including an AMD K62, as well as Celerons
and other Pentium flavors.

					-Erik

--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list