depmod?

J.A. Neitzel jan.listbox at belvento.org
Tue Jul 18 11:17:28 PDT 2000


On Tue, 18 Jul 2000, Thomas 'Balu' Walter said this:
> First of all - new modutils-package is out :)
> 2.3.12...

Ayup, I installed it and am using it with absolutely no problems.

> But I got problems with my modules (integrated everything
> into the kernel up to now).. Doing depmod gives me:
> 
> su-2.04# depmod 
> depmod: QM_MODULES: Function not implemented

Sounds like you are currently running a non-modular kernel. I have
seen that very same error only when I was running my non-modular
kernel.

> This happens with all depmod-versions I tried... So I thought it was
> a problem with the kernel - recompilation did not work.
> 
> Has anyone seen this before?

You built a new modular kernel and did something like...
`make modules && make modules_install` ?

If so, reboot with your new kernel and then do:
su-2.04# depmod -a

I attached the little init script I use to do this.
--
Regards,
J.A. Neitzel
jan at belvento.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: modules.gz
Type: application/x-gzip
Size: 294 bytes
Desc: modules init script
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-dev/attachments/20000718/2af8b8a7/attachment.bin>


More information about the lfs-dev mailing list