checkfs script - something i noticed (forcing fsck)

Gerard Beekmans gerard at linuxfromscratch.org
Wed Jul 12 04:15:23 PDT 2000


> Has anyone ever tried to `shutdown -rF now` -or- `shutdown -hF now`,
> where the "-F" is supposed to "Force fsck on reboot", and noticed
> that the force fsck does not happen the next time you boot?
> 
> Well, I stumbled across this and fixed it. The script uses
> "/forcecheck" where it should instead use "/forcefsck" ... Also of
> note, "rm /forcefsck" may not work since filesystem is mounted ro at
> that point. You can move the "rm /forcefsck" to somewhere else and do
> it when it's mounted rw.

Somebody changed the file name on me, or it has been wrong all along.
Either way it's on the TODO list and will be fixed later today. Thanks.

-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-
--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list