what i did / what did i do wrong ?

bruce at smalltownpoets.net bruce at smalltownpoets.net
Mon Oct 27 07:49:24 PST 2003


Ok i will try and make this brief by describing what i wanted to happen and
how i made it happen in a very round about way. hopefully someone can show
me the error in my way.



I was building lfs 4.1 for the 7th time and decided I wanted to attempt it
this time with no host os installed on the machine.

The following worked but i know there are easier ways can someone show me
how?





1. i downloaded  Jeremy Utley's live lfs cd.



2. Verified that it booted



3. Checked ifconfig for an ip address

    this is where the first problem occured all I had was lo



4. I goggled how to install my 3c59x by hand.

    I ran insmod 3c59x and it found the card

    then edited /etc/modules.conf to show alias eth0 3c59x

    logged out and back in



5. checked ifocnfig and eth0 was now there with no ip



6. tried starting dhcpd by hand  still no ip



7. i ran ifconfig eth0 192.168.0.107



8. i then had the ip 192.168.0.107



9. I pinged 192.168.0.106 and got a response so i knew i had traffic



10. tried pinging www.yahoo.com nothing so i assumed simply a dns issue
tried pinging  216.109.118.69 (yahoo's ip) still nothing. Therefore I had
traffic within my router but nothing external?



11 not knowing how to get web traffic to the machine I simply loaded an ftp
server to my win machine  mounted my /usr drive on the lfs hard drive and
copied the lfs4.1 packages to it that away.



Problem solved.

What would have been nice is if once the live cd was loaded the cd could be
temporarily unmounted so i could mount the cd with the lfs packages on it
and copy them or simply have web access.







Thanks

Bruce

www.smalltownpoets.net





More information about the lfs-chat mailing list