chroot

Albert Wagner alwagner at tcac.net
Wed May 22 12:32:12 PDT 2002


On Wednesday 22 May 2002 01:13 pm, you wrote:
> On Wed, May 22, 2002 at 12:37:53PM -0500, Albert Wagner wrote:
> > Is it possible to access host files from within chrooted environment? 
> > The host is already mounted so I can't mount it within chroot.
>
> in the host system, do
>
> mount --bind <hostdir> <chroot_target_dir>
>
> that will 'bind' the host directory to a directory in the chroot
> envirnment.
>
> Justin 'Gandalf' Hibbits

I tried the above mount --bind command but it complained that there was no 
file system specified.  So I read the mount man page and noticed that "bind" 
is a sort of pseudo file system.  There was no mention of --bind, though I 
saw that construct on a web page.  I then tried mount -t bind and it 
complained that the bind fs was not compiled into the kernel.  I checked the 
menuconfig and found no reference to bind.  From what I read the 
--bind/-tbind options are only available on Linux 2.4.x and my host is older. 
 I will try it after doing a real boot into LFS 3.3.

-- 
Quantum Mechanics: The dreams stuff is made of
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-chat' in the subject header of the message



More information about the lfs-chat mailing list