r7377 - in trunk/BOOK: . chapter01 chapter03 chapter06

matthew at linuxfromscratch.org matthew at linuxfromscratch.org
Sun Feb 19 12:13:26 PST 2006


Author: matthew
Date: 2006-02-19 13:13:22 -0700 (Sun, 19 Feb 2006)
New Revision: 7377

Modified:
   trunk/BOOK/chapter01/changelog.xml
   trunk/BOOK/chapter01/whatsnew.xml
   trunk/BOOK/chapter03/packages.xml
   trunk/BOOK/chapter03/patches.xml
   trunk/BOOK/chapter06/perl.xml
   trunk/BOOK/general.ent
   trunk/BOOK/patches.ent
Log:
Upgrade to Perl 5.8.8

Modified: trunk/BOOK/chapter01/changelog.xml
===================================================================
--- trunk/BOOK/chapter01/changelog.xml	2006-02-19 20:08:26 UTC (rev 7376)
+++ trunk/BOOK/chapter01/changelog.xml	2006-02-19 20:13:22 UTC (rev 7377)
@@ -40,6 +40,10 @@
       <para>Febraury 19, 2006</para>
       <itemizedlist>
         <listitem>
+          <para>[matthew] - Upgrade to Perl-5.8.8, removing the now unneeded
+          vulnerability and DB module patches.</para>
+        </listitem>
+        <listitem>
           <para>[matthew] - Add the verbose parameter to a couple of commands in
           Linux-Libc-Headers and DB.</para>
         </listitem>

Modified: trunk/BOOK/chapter01/whatsnew.xml
===================================================================
--- trunk/BOOK/chapter01/whatsnew.xml	2006-02-19 20:08:26 UTC (rev 7376)
+++ trunk/BOOK/chapter01/whatsnew.xml	2006-02-19 20:13:22 UTC (rev 7377)
@@ -232,9 +232,6 @@
       <para>&mktemp-tempfile-patch;</para>
     </listitem>
     <listitem>
-      <para>&perl-db_file-patch;</para>
-    </listitem>
-    <listitem>
       <para>&perl-libc-patch;</para>
     </listitem>
     <listitem>

Modified: trunk/BOOK/chapter03/packages.xml
===================================================================
--- trunk/BOOK/chapter03/packages.xml	2006-02-19 20:08:26 UTC (rev 7376)
+++ trunk/BOOK/chapter03/packages.xml	2006-02-19 20:13:22 UTC (rev 7377)
@@ -342,7 +342,7 @@
     </varlistentry>
 
     <varlistentry>
-      <term>Perl (&perl-version;) - 9,628 KB:</term>
+      <term>Perl (&perl-version;) - 9,886 KB:</term>
       <listitem>
         <para><ulink url="http://ftp.funet.fi/pub/CPAN/src/"/></para>
       </listitem>

Modified: trunk/BOOK/chapter03/patches.xml
===================================================================
--- trunk/BOOK/chapter03/patches.xml	2006-02-19 20:08:26 UTC (rev 7376)
+++ trunk/BOOK/chapter03/patches.xml	2006-02-19 20:13:22 UTC (rev 7377)
@@ -168,13 +168,6 @@
     </varlistentry>
 
     <varlistentry>
-      <term>Perl DB_File Module Update patch - 6 KB:</term>
-      <listitem>
-        <para><ulink url="&patches-root;&perl-db_file-patch;"/></para>
-      </listitem>
-    </varlistentry>
-
-    <varlistentry>
       <term>Perl Libc Patch - 1 KB:</term>
       <listitem>
         <para><ulink url="&patches-root;&perl-libc-patch;"/></para>
@@ -182,13 +175,6 @@
     </varlistentry>
 
     <varlistentry>
-      <term>Perl Sprintf Vulnerability Patch - 9 KB:</term>
-      <listitem>
-        <para><ulink url="&patches-root;&perl-sprintf-patch;"/></para>
-      </listitem>
-    </varlistentry>
-
-    <varlistentry>
       <term>Sysklogd 8-Bit Cleanness Patch - 1 KB:</term>
       <listitem>
         <para><ulink url="&patches-root;&sysklogd-8bit-patch;"/></para>

Modified: trunk/BOOK/chapter06/perl.xml
===================================================================
--- trunk/BOOK/chapter06/perl.xml	2006-02-19 20:08:26 UTC (rev 7376)
+++ trunk/BOOK/chapter06/perl.xml	2006-02-19 20:13:22 UTC (rev 7377)
@@ -44,17 +44,6 @@
   <sect2 role="installation">
     <title>Installation of Perl</title>
 
-    <para>A security vulnerability exists in Perl's sprintf function. Apply the
-    following patch to fix it.</para>
-
-<screen><userinput>patch -Np1 -i ../&perl-sprintf-patch;</userinput></screen>
-
-    <para>The DB_File module that comes with Perl-&perl-version; is incompatible
-    with Berkeley DB-&db-version; (the testsuite fails if this module gets built).
-    Apply the following patch in order to update the DB_File module:</para>
-
-<screen><userinput>patch -Np1 -i ../&perl-db_file-patch;</userinput></screen>
-
     <para>First create a basic <filename>/etc/hosts</filename> file which will be
     referenced in one of Perl's configuration files as well as being used used by
     the testsuite if you run that.</para>

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2006-02-19 20:08:26 UTC (rev 7376)
+++ trunk/BOOK/general.ent	2006-02-19 20:13:22 UTC (rev 7377)
@@ -72,7 +72,7 @@
 <!ENTITY ncurses-version "5.5">
 <!-- <!ENTITY ncurses-date "20050319"> -->
 <!ENTITY patch-version "2.5.4">
-<!ENTITY perl-version "5.8.7">
+<!ENTITY perl-version "5.8.8">
 <!ENTITY procps-version "3.2.6">
 <!ENTITY psmisc-version "22.1">
 <!ENTITY readline-version "5.1">

Modified: trunk/BOOK/patches.ent
===================================================================
--- trunk/BOOK/patches.ent	2006-02-19 20:08:26 UTC (rev 7376)
+++ trunk/BOOK/patches.ent	2006-02-19 20:13:22 UTC (rev 7377)
@@ -37,9 +37,7 @@
 <!ENTITY ncurses-fixes-patch "ncurses-&ncurses-version;-fixes-1.patch">
 <!-- <!ENTITY ncurses-rollup-patch "ncurses-&ncurses-version;-&ncurses-date;-patch.sh.bz2"> -->
 
-<!ENTITY perl-db_file-patch "perl-&perl-version;-update_db_file-1.patch">
 <!ENTITY perl-libc-patch "perl-&perl-version;-libc-1.patch">
-<!ENTITY perl-sprintf-patch "perl-&perl-version;-sprintf_vulnerability-1.patch">
 
 <!ENTITY sysklogd-8bit-patch "sysklogd-&sysklogd-version;-8bit-1.patch">
 <!ENTITY sysklogd-fixes-patch "sysklogd-&sysklogd-version;-fixes-1.patch">




More information about the lfs-book mailing list