r402 - in trunk/BOOK: . chapter01 chapter07

robert at linuxfromscratch.org robert at linuxfromscratch.org
Thu Mar 17 21:00:35 PST 2005


Author: robert
Date: 2005-03-17 22:00:34 -0700 (Thu, 17 Mar 2005)
New Revision: 402

Modified:
   trunk/BOOK/chapter01/changelog.xml
   trunk/BOOK/chapter07/kernel.xml
   trunk/BOOK/general.ent
Log:
upgrade kernel version

Modified: trunk/BOOK/chapter01/changelog.xml
===================================================================
--- trunk/BOOK/chapter01/changelog.xml	2005-03-18 04:10:21 UTC (rev 401)
+++ trunk/BOOK/chapter01/changelog.xml	2005-03-18 05:00:34 UTC (rev 402)
@@ -63,7 +63,7 @@
 <listitem><para>libol-0.3.15</para></listitem>
 <listitem><para>libpng-1.2.8</para></listitem>
 <listitem><para>libtool-1.5.14</para></listitem>
-<listitem><para>linux-2.6.11.2</para></listitem>
+<listitem><para>linux-2.6.11.4</para></listitem>
 <listitem><para>linux-libc-headers-2.6.11.0</para></listitem>
 <listitem><para>m4-1.4.2</para></listitem>
 <listitem><para>make-3.80</para></listitem>
@@ -111,6 +111,9 @@
 <listitem><para>March 17th, 2005 [Archaic]: Updated blfs-bootscripts to
 20050313.</para></listitem>
 
+<listitem><para>March 17th, 2005 [Robert]: Upgrade to
+linux-2.6.11.4.</para></listitem>
+
 <listitem><para>March 16th, 2005 [Robert]: Added configs to udev
 page.</para></listitem>
 

Modified: trunk/BOOK/chapter07/kernel.xml
===================================================================
--- trunk/BOOK/chapter07/kernel.xml	2005-03-18 04:10:21 UTC (rev 401)
+++ trunk/BOOK/chapter07/kernel.xml	2005-03-18 05:00:34 UTC (rev 402)
@@ -59,11 +59,16 @@
 <screen><userinput>install -m444 /sources/linux-&linux-version;-pseudo_random-1.patch /usr/src
 install -m444 /sources/grsecurity-2.1.3-&linux-version;-200503111604.patch /usr/src</userinput></screen>
 
-<para>Then change to the Linux source directory and apply the patches:</para>
+<para>Then change to the Linux source directory and apply the patches. Four
+hunks will be rejected. The grsecurity patch is made to apply to kernel 2.6.11.
+The rejected parts are harmless in this instance because the grsecurity patch
+is trying to patch parts which have already been fixed in version 2.6.11.4. The
+sed command will adjust the extra version string:</para>
 
 <screen><userinput>cd /usr/src/linux-&linux-version;
 patch -Np1 -i ../linux-&linux-version;-pseudo_random-1.patch
-patch -Np1 -i ../grsecurity-2.1.3-&linux-version;-200503111604.patch</userinput></screen>
+patch -Np1 -i ../grsecurity-2.1.3-&linux-version;-200503111604.patch
+sed -e 's/^EXTRAVERSION .*$/&-grsec/' -i Makefile</userinput></screen>
 
 <tip><para>Look at <command>info libc</command>, node <quote>System 
 Configuration</quote>, <quote>General Limits</quote>. There are

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2005-03-18 04:10:21 UTC (rev 401)
+++ trunk/BOOK/general.ent	2005-03-18 05:00:34 UTC (rev 402)
@@ -51,7 +51,7 @@
 <!ENTITY lfs-bootscripts-version "3.1.0">
 <!ENTITY libol-version "0.3.15">
 <!ENTITY libtool-version "1.5.14">
-<!ENTITY linux-version "2.6.11.2">
+<!ENTITY linux-version "2.6.11.4">
 <!ENTITY linux-libc-headers-version "2.6.11.0">
 <!ENTITY m4-version "1.4.2">
 <!ENTITY make-version "3.80">




More information about the hlfs-book mailing list