[elinks-dev] Fw: [elinks-users] ELinks cannot run perl scripts that use perl modules.

أحمد المحمودي aelmahmoudy at users.sourceforge.net
Fri Sep 26 07:52:55 PDT 2008


Hello,

  I am forwarding this from elinks-users list.

On Tue, Sep 23, 2008 at 10:37:34AM +0300, Kalle Olavi Niemitalo wrote:
> I think this causes the error with XML::LibXML::SAX, too.  In the
> perlembed man page, there is some advice about "dynamic loading
> not available".  Apparently, we'd have to link the DynaLoader
> library of Perl statically into ELinks.  In my machine, it appears
> to be at /usr/lib/perl/5.8.8/auto/DynaLoader/DynaLoader.a, but
> I don't know how elinks/configure should locate that file.
---end quoted text---

  From the perlembed manpage I found this: 
  perl -MExtUtils::Embed -e ccopts -e ldopts

  when I ran it I got:

-Wl,-E  -L/usr/local/lib /usr/lib/perl/5.8/auto/DynaLoader/DynaLoader.a -L/usr/lib/perl/5.8/CORE -lperl -ldl -lm -lpthread -lc -lcrypt
 -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBIAN -fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -I/usr/lib/perl/5.8/CORE 

-- 
 أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
  SySDSoft, Inc.
 GPG KeyID: 0x9DCA0B27 (@ subkeys.pgp.net)
 GPG Fingerprint: 087D 3767 8CAC 65B1 8F6C  156E D325 C3C8 9DCA 0B27



More information about the elinks-dev mailing list